Info news wiki : Quel logiciel est nécessaire pour exécuter RW CAREWare?

CAREWare est un programme entièrement gratuit et évolutif pour améliorer et contrôler la santé du VIH et les soins de soutien. Il est en mesure de produire un rapport sur le VIH / sida (RSR) mandaté par la HRSA. CARE peut être organisé dans une variété de paramètres en fonction du nombre d'utilisateurs dans la clinique. D'un réseau étendu (WAN) à un seul autonome, vous pourrez adapter RW CAREWare pour répondre à chacune de vos exigences cliniques.

Trois niveaux sont requis pour que CAREWare fonctionne correctement: le niveau métier, le niveau client et le niveau données. Ces niveaux représentent l'interface utilisateur graphique (niveau client), le middleware (niveau entreprise) et la base de données qui stocke toutes les données saisies dans CAREWare (niveau données). Le segment de ressources le plus intensif de RW CAREWare est la base de données SQL Server nécessaire qui inclut toutes les données personnelles entrées.

CAREWare peut fonctionner sous Windows OS de Windows 2000 à Windows 7. Les seuls produits obligatoires sont The24 Framework et Windows OS. Selon la version et le système d'exploitation, vous devrez peut-être créer des logiciels supplémentaires pour permettre à CAREWare de fonctionner efficacement.

RW CAREWare version 4.1

Pour exécuter RW CAREWare 4.1, vous devez disposer de .NET Framework 1.1 sur votre PC. Une fois que vous avez déployé le package redistribué, vous serez invité à le recevoir et à le configurer. 1.1 Service Pack 1.1

La configuration matérielle requise pour 4.1 n'est pas très stricte, donc si votre bureau est suffisamment à jour, vous ne devriez pas avoir de problème. Vous devrez probablement créer des logiciels en cours pour que CAREWare fonctionne efficacement:

1. MDAC 2.8
2. Analyseur XML 6.0
3. Windows Installer 3.1

RW CAREWare version 5

Les programmes suivants sont nécessaires pour une installation correcte de la version 5.0 de RW CAREWare.

1. Programme d'installation de Windows 4.5 redistribué
2 .. Package redistribuable NET Framework version 2.0
3. .NET 2.0 Service Pack 2 est uniquement pour Windows Server 2003 et Windows XP..NET 2.0 SP2 n'est pas disponible en téléchargement séparé sur Windows Vista et Windows Server 2008; sur ces PC, vous devrez monter le .NET Framework 3.5 SP1, qui est fourni avec .NET 2.0 SP2.

Remarque: Téléchargez et montez NetFx20SP2_x86.exe sauf si vous utilisez bien sûr une machine 64 bits.

4 .. NET Framework 3.5 SP1

Remarque: les instances de Windows 7 par défaut ont .NET Framework 3.5 SP1..Avec Net Framework 3.5 a 2.0 framework enveloppé en elle. Framework 3.5 de livraison supplémentaire avec Windows Server 2008 R2 en tant que module supplémentaire (désactivé par défaut).